install pip 3.6

All other Source.Python topics and issues.
ErnestTBass
Junior Member
Posts: 13
Joined: Sun Mar 31, 2019 6:37 pm

install pip 3.6

Postby ErnestTBass » Tue Apr 02, 2019 3:46 am

I am trying to install the latest version of pip-pip3.6. I already have python 3.6 installed. When I do I get the following error. I am not sure what they mean:

python3.6 -m pip install
You must give at least one requirement to install (see "pip help install")
You are using pip version 8.1.1, however version 19.0.3 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

Of course, I am referring to the first two lines of the error. However, when i do I get this error. How do I fix it? Again this is pip 3.6.

Respectfully,

Newport_j
User avatar
Ayuto
Project Leader
Posts: 2018
Joined: Sat Jul 07, 2012 8:17 am
Location: Germany

Re: install pip 3.6

Postby Ayuto » Tue Apr 02, 2019 8:35 am

The command is incomplete. pip is a tool to install site-packages. You need to tell pip what it should install:
python3.6 -m pip install <package to install>

If you want to upgrade pip, run the following command:
python3.6 -m pip install --upgrade pip
ErnestTBass
Junior Member
Posts: 13
Joined: Sun Mar 31, 2019 6:37 pm

Re: install pip 3.6

Postby ErnestTBass » Tue Apr 02, 2019 1:14 pm

Okay, I will try. if I am successful in ulgrading to pip 3.6. How do I refer to it.

pip3. pip3.6 ?

Any help appreciated. Thanks in advance.

Respectfully,

ErnestTBass
User avatar
Ayuto
Project Leader
Posts: 2018
Joined: Sat Jul 07, 2012 8:17 am
Location: Germany

Re: install pip 3.6

Postby Ayuto » Tue Apr 02, 2019 7:27 pm

There are multiple ways:
pip install <package to install>
pip3 install <package to install>
pip3.6 install <package to install>
python3.6 -m pip install <package to install>

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 4 guests