[CSS/CSGO] Warcraft: Source

Release your plugins here!
Hirra
Junior Member
Posts: 5
Joined: Mon Apr 01, 2019 2:06 pm

Re: [CSS/CSGO] Warcraft: Source

Postby Hirra » Mon Jun 24, 2019 10:40 pm

TPDerp wrote:Some player_spawn skills/items that modify a player's health (etc.) might not work correctly on CS:GO. Try to change it to post_player_spawn and see if that solves the problem.

Yes, that's work.
But I found a new bug.

Code: Select all

[[periapthp50]]
name        = "HP (+50HP)"
desc        = ""
cost        = 3000
level       = 0
dab         = 1 #0=death, 1=alive, 2=both
duration    = 1 #0=this round, 1=untill death
max         = 2
cfg         = "post_player_spawn"
cmdbuy      = "es wcs_setfx health server_var(wcs_userid) + 50 0"
cmdactivate = "es wcs_setfx health event_var(userid) + 50 0"


1)Now if I buy that (for example) item 2 times - in the next round it is activated only once.
Instead of 100 hp, I get 50 hp.
2)Also, this item after the first purchase continues to be activated every round, even after death in the case of duration = "1", without a second purchase.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Tue Jun 25, 2019 6:00 pm

Hirra wrote:
TPDerp wrote:Some player_spawn skills/items that modify a player's health (etc.) might not work correctly on CS:GO. Try to change it to post_player_spawn and see if that solves the problem.

Yes, that's work.
But I found a new bug.

Code: Select all

[[periapthp50]]
name        = "HP (+50HP)"
desc        = ""
cost        = 3000
level       = 0
dab         = 1 #0=death, 1=alive, 2=both
duration    = 1 #0=this round, 1=untill death
max         = 2
cfg         = "post_player_spawn"
cmdbuy      = "es wcs_setfx health server_var(wcs_userid) + 50 0"
cmdactivate = "es wcs_setfx health event_var(userid) + 50 0"


1)Now if I buy that (for example) item 2 times - in the next round it is activated only once.
Instead of 100 hp, I get 50 hp.
2)Also, this item after the first purchase continues to be activated every round, even after death in the case of duration = "1", without a second purchase.

That'd be fixed as well in the newest version.
Hirra
Junior Member
Posts: 5
Joined: Mon Apr 01, 2019 2:06 pm

Re: [CSS/CSGO] Warcraft: Source

Postby Hirra » Wed Jun 26, 2019 10:30 pm

TPDerp wrote:That'd be fixed as well in the newest version.


Yes. Now the shopmenu works without any errors.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Thu Jun 27, 2019 5:15 pm

Hirra wrote:
TPDerp wrote:That'd be fixed as well in the newest version.


Yes. Now the shopmenu works without any errors.

Great! Let me know if you find any other issue.
User avatar
BackRaw
Senior Member
Posts: 529
Joined: Sun Jul 15, 2012 1:46 am
Location: Germany
Contact:

Re: [CSS/CSGO] Warcraft: Source

Postby BackRaw » Sat Jul 06, 2019 8:48 pm

How do I get/install the ES races?
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Sun Jul 07, 2019 6:46 pm

BackRaw wrote:How do I get/install the ES races?

You can find old-style races here and here as well as various other places. To install these races, you can follow this guide. Let me know if you have any other questions.
User avatar
BackRaw
Senior Member
Posts: 529
Joined: Sun Jul 15, 2012 1:46 am
Location: Germany
Contact:

Re: [CSS/CSGO] Warcraft: Source

Postby BackRaw » Mon Jul 15, 2019 12:08 am

TPDerp wrote:
BackRaw wrote:How do I get/install the ES races?

You can find old-style races here and here as well as various other places. To install these races, you can follow this guide. Let me know if you have any other questions.

Alright, thanks. I'll look into it.
Mix159
Junior Member
Posts: 4
Joined: Wed Jul 17, 2019 5:32 am

Re: [CSS/CSGO] Warcraft: Source

Postby Mix159 » Wed Jul 17, 2019 6:00 am

TPDerp wrote:
BackRaw wrote:How do I get/install the ES races?

You can find old-style races here and here as well as various other places. To install these races, you can follow this guide. Let me know if you have any other questions.


Hey, I haven't been able to make old ES races appear on the changerace menu, only the 4 basic ones from the repository. For reference, I'm trying to install Holliday's racepack, and the console tells me that his races are actually being loaded. Thanks.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Wed Jul 17, 2019 8:50 am

Mix159 wrote:Hey, I haven't been able to make old ES races appear on the changerace menu, only the 4 basic ones from the repository. For reference, I'm trying to install Holliday's racepack, and the console tells me that his races are actually being loaded. Thanks.

Did you move the actual races to the correct file? INI-style races go in the "cfg/source-python/wcs/races.ini" while keygroup-style races go in the "cfg/source-python/wcs/es_WCSraces_db.txt" file. If you did, do you get any exceptions in the logs?
Mix159
Junior Member
Posts: 4
Joined: Wed Jul 17, 2019 5:32 am

Re: [CSS/CSGO] Warcraft: Source

Postby Mix159 » Wed Jul 17, 2019 5:23 pm

TPDerp wrote:
Mix159 wrote:Hey, I haven't been able to make old ES races appear on the changerace menu, only the 4 basic ones from the repository. For reference, I'm trying to install Holliday's racepack, and the console tells me that his races are actually being loaded. Thanks.

Did you move the actual races to the correct file? INI-style races go in the "cfg/source-python/wcs/races.ini" while keygroup-style races go in the "cfg/source-python/wcs/es_WCSraces_db.txt" file. If you did, do you get any exceptions in the logs?


The races are in the correct place and this is all the console tells me, but as far as I know there souldn't be any { or } in these files?

Code: Select all

[SP] Loading plugin 'es_emulator'...
[EventScripts] Loaded esc
[SP] Successfully loaded plugin 'es_emulator'.
[SP] Loading plugin 'wcs'...
KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt


[SP] Encountered a Warning:
  File '..\addons\source-python\plugins\wcs\core\modules\oldesc.py', line 268: UserWarning
    Unable to find the "es_WCSlanguage_db" file.


[SP] Encountered a Warning:
  File '..\addons\source-python\plugins\wcs\core\modules\races\manager.py', line 199: UserWarning
    Unable to find the default race "". Using "undead_scourge" as temporary default
        race.

[SP] Successfully loaded plugin 'wcs'.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Wed Jul 17, 2019 8:10 pm

Mix159 wrote:
TPDerp wrote:
Mix159 wrote:Hey, I haven't been able to make old ES races appear on the changerace menu, only the 4 basic ones from the repository. For reference, I'm trying to install Holliday's racepack, and the console tells me that his races are actually being loaded. Thanks.

Did you move the actual races to the correct file? INI-style races go in the "cfg/source-python/wcs/races.ini" while keygroup-style races go in the "cfg/source-python/wcs/es_WCSraces_db.txt" file. If you did, do you get any exceptions in the logs?


The races are in the correct place and this is all the console tells me, but as far as I know there souldn't be any { or } in these files?

Code: Select all

[SP] Loading plugin 'es_emulator'...
[EventScripts] Loaded esc
[SP] Successfully loaded plugin 'es_emulator'.
[SP] Loading plugin 'wcs'...
KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt


[SP] Encountered a Warning:
  File '..\addons\source-python\plugins\wcs\core\modules\oldesc.py', line 268: UserWarning
    Unable to find the "es_WCSlanguage_db" file.


[SP] Encountered a Warning:
  File '..\addons\source-python\plugins\wcs\core\modules\races\manager.py', line 199: UserWarning
    Unable to find the default race "". Using "undead_scourge" as temporary default
        race.

[SP] Successfully loaded plugin 'wcs'.

Rename the file to "races.ini", and that'd fix it. You might've mixed up what's INI and keygroup races. INI races looks like this (and are placed in races.ini):

Code: Select all

[I'm a INI race]
    required       = 0
    maximum        = 0
    restrictmap    = ""
    restrictteam   = 0
    restrictitem   = ""
    teamlimit      = 0
    author         = ""
    desc           = ""
    spawncmd       = ""
    deathcmd       = ""
    roundstartcmd  = ""
    roundendcmd    = ""
    preloadcmd     = ""
    allowonly      = ""
    onchange       = ""
    numberofskills = 0
    numberoflevels = 0
    skillnames     = ""
    skilldescr     = ""
    skillcfg       = ""
    skillneeded    = ""
    category       = ""

While keygroup looks like this (and are placed in es_WCSraces_db.txt):

Code: Select all

"1"
{
    "name"              "I'm a keygroup race"
    "author"            ""
    "shortdescription"  ""
    "required_level"    "0"
    "maximum_level"     "0"
    "allow_only"        "0"
    "teamlimit"         "0"
    "restrict_shop"     ""
    "preloadcmd"        "0"
    "player_spawn_cmd"  "0"
    "round_start_cmd"   "0"
    "round_end_cmd"     "0"
    "numberofskills"    "4"
    "numberoflevels"    "8"
    "skillnames"        ""
    "skilldescr"        ""
    "skillcfg"          ""
}
Mix159
Junior Member
Posts: 4
Joined: Wed Jul 17, 2019 5:32 am

Re: [CSS/CSGO] Warcraft: Source

Postby Mix159 » Thu Jul 18, 2019 4:12 am

TPDerp wrote:
Mix159 wrote:
TPDerp wrote:Did you move the actual races to the correct file? INI-style races go in the "cfg/source-python/wcs/races.ini" while keygroup-style races go in the "cfg/source-python/wcs/es_WCSraces_db.txt" file. If you did, do you get any exceptions in the logs?


The races are in the correct place and this is all the console tells me, but as far as I know there souldn't be any { or } in these files?

Code: Select all

[SP] Loading plugin 'es_emulator'...
[EventScripts] Loaded esc
[SP] Successfully loaded plugin 'es_emulator'.
[SP] Loading plugin 'wcs'...
KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt

KeyValues Error: LoadFromBuffer: missing { in file d:\arquivos\server csgo\csgosl\server\csgo\cfg\source-python\wcs\es_WCSraces_db.txt


[SP] Encountered a Warning:
  File '..\addons\source-python\plugins\wcs\core\modules\oldesc.py', line 268: UserWarning
    Unable to find the "es_WCSlanguage_db" file.


[SP] Encountered a Warning:
  File '..\addons\source-python\plugins\wcs\core\modules\races\manager.py', line 199: UserWarning
    Unable to find the default race "". Using "undead_scourge" as temporary default
        race.

[SP] Successfully loaded plugin 'wcs'.

Rename the file to "races.ini", and that'd fix it. You might've mixed up what's INI and keygroup races. INI races looks like this (and are placed in races.ini):

Code: Select all

[I'm a INI race]
    required       = 0
    maximum        = 0
    restrictmap    = ""
    restrictteam   = 0
    restrictitem   = ""
    teamlimit      = 0
    author         = ""
    desc           = ""
    spawncmd       = ""
    deathcmd       = ""
    roundstartcmd  = ""
    roundendcmd    = ""
    preloadcmd     = ""
    allowonly      = ""
    onchange       = ""
    numberofskills = 0
    numberoflevels = 0
    skillnames     = ""
    skilldescr     = ""
    skillcfg       = ""
    skillneeded    = ""
    category       = ""

While keygroup looks like this (and are placed in es_WCSraces_db.txt):

Code: Select all

"1"
{
    "name"              "I'm a keygroup race"
    "author"            ""
    "shortdescription"  ""
    "required_level"    "0"
    "maximum_level"     "0"
    "allow_only"        "0"
    "teamlimit"         "0"
    "restrict_shop"     ""
    "preloadcmd"        "0"
    "player_spawn_cmd"  "0"
    "round_start_cmd"   "0"
    "round_end_cmd"     "0"
    "numberofskills"    "4"
    "numberoflevels"    "8"
    "skillnames"        ""
    "skilldescr"        ""
    "skillcfg"          ""
}


You're right, I messed up the file names. However, I just changed it to races.ini and these showed up on the console.

Code: Select all

[SP] Successfully loaded plugin 'es_emulator'.
[SP] Loading plugin 'wcs'...

[SP] Caught an Exception:
Traceback (most recent call last):
  File "..\addons\source-python\packages\source-python\plugins\command.py", line 162, in load_plugin
    plugin = self.manager.load(plugin_name)
  File "..\addons\source-python\packages\source-python\plugins\manager.py", line 194, in load
    plugin._load()
  File "..\addons\source-python\packages\source-python\plugins\instance.py", line 76, in _load
    self.module.load()
  File "..\addons\source-python\plugins\wcs\wcs.py", line 239, in load
    race_manager.update(parse_ini_races())
  File "..\addons\source-python\plugins\wcs\core\modules\oldesc.py", line 102, in parse_ini_races
    imported = ConfigObj(CFG_PATH / 'races.ini')
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1229, in __init__
    self._load(infile, configspec)
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1318, in _load
    raise error
  File "<string>", line None

configobj.ConfigObjError: Parsing failed with several errors.
First error at line 134.


[SP] Plugin 'wcs' was unable to be loaded.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Thu Jul 18, 2019 7:58 pm

Mix159 wrote:
TPDerp wrote:Rename the file to "races.ini", and that'd fix it. You might've mixed up what's INI and keygroup races. INI races looks like this (and are placed in races.ini):

Code: Select all

[I'm a INI race]
    required       = 0
    maximum        = 0
    restrictmap    = ""
    restrictteam   = 0
    restrictitem   = ""
    teamlimit      = 0
    author         = ""
    desc           = ""
    spawncmd       = ""
    deathcmd       = ""
    roundstartcmd  = ""
    roundendcmd    = ""
    preloadcmd     = ""
    allowonly      = ""
    onchange       = ""
    numberofskills = 0
    numberoflevels = 0
    skillnames     = ""
    skilldescr     = ""
    skillcfg       = ""
    skillneeded    = ""
    category       = ""

While keygroup looks like this (and are placed in es_WCSraces_db.txt):

Code: Select all

"1"
{
    "name"              "I'm a keygroup race"
    "author"            ""
    "shortdescription"  ""
    "required_level"    "0"
    "maximum_level"     "0"
    "allow_only"        "0"
    "teamlimit"         "0"
    "restrict_shop"     ""
    "preloadcmd"        "0"
    "player_spawn_cmd"  "0"
    "round_start_cmd"   "0"
    "round_end_cmd"     "0"
    "numberofskills"    "4"
    "numberoflevels"    "8"
    "skillnames"        ""
    "skilldescr"        ""
    "skillcfg"          ""
}


You're right, I messed up the file names. However, I just changed it to races.ini and these showed up on the console.

Code: Select all

[SP] Successfully loaded plugin 'es_emulator'.
[SP] Loading plugin 'wcs'...

[SP] Caught an Exception:
Traceback (most recent call last):
  File "..\addons\source-python\packages\source-python\plugins\command.py", line 162, in load_plugin
    plugin = self.manager.load(plugin_name)
  File "..\addons\source-python\packages\source-python\plugins\manager.py", line 194, in load
    plugin._load()
  File "..\addons\source-python\packages\source-python\plugins\instance.py", line 76, in _load
    self.module.load()
  File "..\addons\source-python\plugins\wcs\wcs.py", line 239, in load
    race_manager.update(parse_ini_races())
  File "..\addons\source-python\plugins\wcs\core\modules\oldesc.py", line 102, in parse_ini_races
    imported = ConfigObj(CFG_PATH / 'races.ini')
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1229, in __init__
    self._load(infile, configspec)
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1318, in _load
    raise error
  File "<string>", line None

configobj.ConfigObjError: Parsing failed with several errors.
First error at line 134.


[SP] Plugin 'wcs' was unable to be loaded.

Code: Select all

  File "..\addons\source-python\plugins\wcs\core\modules\oldesc.py", line 102, in parse_ini_races
    imported = ConfigObj(CFG_PATH / 'races.ini')
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1229, in __init__
    self._load(infile, configspec)
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1318, in _load
    raise error
  File "<string>", line None

configobj.ConfigObjError: Parsing failed with several errors.
First error at line 134.


[SP] Plugin 'wcs' was unable to be loaded.

It appears you have an error on line 134 in your races.ini file.
Mix159
Junior Member
Posts: 4
Joined: Wed Jul 17, 2019 5:32 am

Re: [CSS/CSGO] Warcraft: Source

Postby Mix159 » Thu Jul 18, 2019 8:53 pm

TPDerp wrote:
Mix159 wrote:
TPDerp wrote:Rename the file to "races.ini", and that'd fix it. You might've mixed up what's INI and keygroup races. INI races looks like this (and are placed in races.ini):

Code: Select all

[I'm a INI race]
    required       = 0
    maximum        = 0
    restrictmap    = ""
    restrictteam   = 0
    restrictitem   = ""
    teamlimit      = 0
    author         = ""
    desc           = ""
    spawncmd       = ""
    deathcmd       = ""
    roundstartcmd  = ""
    roundendcmd    = ""
    preloadcmd     = ""
    allowonly      = ""
    onchange       = ""
    numberofskills = 0
    numberoflevels = 0
    skillnames     = ""
    skilldescr     = ""
    skillcfg       = ""
    skillneeded    = ""
    category       = ""

While keygroup looks like this (and are placed in es_WCSraces_db.txt):

Code: Select all

"1"
{
    "name"              "I'm a keygroup race"
    "author"            ""
    "shortdescription"  ""
    "required_level"    "0"
    "maximum_level"     "0"
    "allow_only"        "0"
    "teamlimit"         "0"
    "restrict_shop"     ""
    "preloadcmd"        "0"
    "player_spawn_cmd"  "0"
    "round_start_cmd"   "0"
    "round_end_cmd"     "0"
    "numberofskills"    "4"
    "numberoflevels"    "8"
    "skillnames"        ""
    "skilldescr"        ""
    "skillcfg"          ""
}


You're right, I messed up the file names. However, I just changed it to races.ini and these showed up on the console.

Code: Select all

[SP] Successfully loaded plugin 'es_emulator'.
[SP] Loading plugin 'wcs'...

[SP] Caught an Exception:
Traceback (most recent call last):
  File "..\addons\source-python\packages\source-python\plugins\command.py", line 162, in load_plugin
    plugin = self.manager.load(plugin_name)
  File "..\addons\source-python\packages\source-python\plugins\manager.py", line 194, in load
    plugin._load()
  File "..\addons\source-python\packages\source-python\plugins\instance.py", line 76, in _load
    self.module.load()
  File "..\addons\source-python\plugins\wcs\wcs.py", line 239, in load
    race_manager.update(parse_ini_races())
  File "..\addons\source-python\plugins\wcs\core\modules\oldesc.py", line 102, in parse_ini_races
    imported = ConfigObj(CFG_PATH / 'races.ini')
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1229, in __init__
    self._load(infile, configspec)
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1318, in _load
    raise error
  File "<string>", line None

configobj.ConfigObjError: Parsing failed with several errors.
First error at line 134.


[SP] Plugin 'wcs' was unable to be loaded.

Code: Select all

  File "..\addons\source-python\plugins\wcs\core\modules\oldesc.py", line 102, in parse_ini_races
    imported = ConfigObj(CFG_PATH / 'races.ini')
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1229, in __init__
    self._load(infile, configspec)
  File "..\addons\source-python\packages\site-packages\configobj.py", line 1318, in _load
    raise error
  File "<string>", line None

configobj.ConfigObjError: Parsing failed with several errors.
First error at line 134.


[SP] Plugin 'wcs' was unable to be loaded.

It appears you have an error on line 134 in your races.ini file.


Edit: Races appear to be working! Thank you for your help, TPDerp.
xancara
Junior Member
Posts: 7
Joined: Tue Feb 24, 2015 5:12 pm

Re: [CSS/CSGO] Warcraft: Source

Postby xancara » Fri Jan 17, 2020 8:35 pm

I seem to be getting a bad db column from the SQLite DB.

Code: Select all

[SP] Caught an Exception:
Traceback (most recent call last):
File "../addons/source-python/plugins/wcs/core/database/thread.py", line 153, in run
self.cur.execute(node.query, node.arguments)


Just installed this fresh from the latest contents and WCS packages.

I also tried to delete the produced .sqlite files to make sure they were being produced fresh and not somehow lingering from a different test but, still getting this.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Mon Jan 20, 2020 9:56 pm

xancara wrote:I seem to be getting a bad db column from the SQLite DB.

Code: Select all

[SP] Caught an Exception:
Traceback (most recent call last):
File "../addons/source-python/plugins/wcs/core/database/thread.py", line 153, in run
self.cur.execute(node.query, node.arguments)

It appears that exception is incomplete. Do you have the rest?
xancara wrote:Just installed this fresh from the latest contents and WCS packages.

I also tried to delete the produced .sqlite files to make sure they were being produced fresh and not somehow lingering from a different test but, still getting this.

I'm unable to reproduce this on a clean install. Have you made any modifications (changed the config, added races and/or items, etc)? Could you post the output of typing "sp info" in the server console?
xancara
Junior Member
Posts: 7
Joined: Tue Feb 24, 2015 5:12 pm

Re: [CSS/CSGO] Warcraft: Source

Postby xancara » Tue Jan 21, 2020 1:03 pm

Sorry for the slow response, and the missing part of that error. I was positive that I put it all in there.

The missing text was something along the lines of invalid database column "accountid"

It just repeated a few hundred times in console.

I have since done a complete server wipe and it seems to be working without throwing that exception now. Maybe it was something that I just didn't manage to wipe out when I was deleting all of the older stuff for the fresh install or some script I had running for backups/restore or something.

Regardless of the original cause, it appears that it is no longer happening.


The new issue i have run into is I can't seem to get items to load in the shop. This is probably just a 'me' problem.

Do you have any example races/items.json to go with the stuff included in wcs-contents?

My races seem to be loading just fine, but my items aren't. I tried to follow the instructions for it in the readme (basically just duped my working races.ini content and replaced it with 'items' and the appropriate list contained in the wcs-contents repo) but still no dice. TBQH, i haven't had a ton of time to focus on the issue so it is probably something very minor. I'll play with it later and update.
User avatar
TPDerp
Junior Member
Posts: 25
Joined: Mon Jul 09, 2012 7:51 pm

Re: [CSS/CSGO] Warcraft: Source

Postby TPDerp » Thu Jan 23, 2020 10:08 pm

xancara wrote:Sorry for the slow response, and the missing part of that error. I was positive that I put it all in there.

Don't worry about it. I'd probably be the one to apologize for the slow responses, hehe.
xancara wrote:The missing text was something along the lines of invalid database column "accountid"

It just repeated a few hundred times in console.

I have since done a complete server wipe and it seems to be working without throwing that exception now. Maybe it was something that I just didn't manage to wipe out when I was deleting all of the older stuff for the fresh install or some script I had running for backups/restore or something.

Regardless of the original cause, it appears that it is no longer happening.

It might've been because it'd still find an old database. I made some changes to the database structure, so it'd work better across games. which might've been the cause to these exceptions.
xancara wrote:The new issue i have run into is I can't seem to get items to load in the shop. This is probably just a 'me' problem.

Do you have any example races/items.json to go with the stuff included in wcs-contents?

My races seem to be loading just fine, but my items aren't. I tried to follow the instructions for it in the readme (basically just duped my working races.ini content and replaced it with 'items' and the appropriate list contained in the wcs-contents repo) but still no dice. TBQH, i haven't had a ton of time to focus on the issue so it is probably something very minor. I'll play with it later and update.

You'd be able to install any races/items from the WCS website, and they'd (mostly) work without any modification. The races/items from the WCS-Contents repository is solely for new-style races/items that can be installed directly from the server.

Return to “Plugin Releases”

Who is online

Users browsing this forum: No registered users and 3 guests