Performance problems with SP at HL2DM

All other Source.Python topics and issues.
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Performance problems with SP at HL2DM

Postby Painkiller » Sat Jul 08, 2017 11:32 am

Hello people I noticed some time ago and also other games of the my server runs uneasily.

I tested without and with sp plugins it changed nothing.

I now set a new server without addons.

The server seemed to run clean.

When I installed SP I got FPS drops. (Without plugins)

Would it be possible for Half Life 2 Deathmatch performance problems with SP?

I would be very happy to answer.

Thanks in Advance


Edit: I have a linux root.
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Sat Aug 05, 2017 2:44 pm

Here again a few more info



- The problem starts with server join
- It is on every map
- Without plugins the same problem


Code: Select all

9:50:43 HLSW Information: Verbinde zu 176.9.155.153:28070 ...
09:50:43 sp info
09:50:43
         Date          : 2017-08-06 07:50:43.656928
         OS            : Linux-4.4.0-79-generic-x86_64-with-debian-jessie-sid
         Game          : hl2dm
         SP version    : 587
         Server plugins:
            00: DoS Attack Fixer, www.sourceop.com
            01: Metamod:Source 1.10.6
            02: PlayerLimitRemover, www.sourceop.com
            03: Spawn/Chat Protection; by Bernt Nilsson, version 3.3.5 beta 2
            04: Source.Python, (C) 2012-2016, Source.Python Team.
         SP plugins:
            00: ads
            01: country_tag, 1.0, https://venomz.fr/
            02: deathmsg
            03: download
            04: gamedesc
            05: killcam
            06: map_cycle, 2.1, https://github.com/KirillMysnik/sp-map-cycle
            07: mapoverlayremove
            08: savescore
            09: scoreboard
            10: sound_trigger
            11: weapon_drop
            12: webshort


Code: Select all

09:58:47 meta list
09:58:47 Listing 2 plugins:
           [02] Keeper's Sound Plugin (HYBRID) (2.3.1.0) by Keeper
           [03] <NOFILE>
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Sat Aug 12, 2017 8:00 am

The problem is still Currently could help me with a solution of the problem?
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Thu Aug 17, 2017 1:49 pm

The problem is still Actuel
decompile
Senior Member
Posts: 324
Joined: Sat Oct 10, 2015 10:37 am
Location: Germany
Contact:

Re: Performance problems with SP at HL2DM

Postby decompile » Thu Aug 17, 2017 7:06 pm

You should rather try to host a clean server with sp only, we see that you have some addons loaded which otherwise could cause that.
User avatar
La Muerte
Administrator
Posts: 176
Joined: Sun Jul 15, 2012 1:48 pm
Location: Belgium
Contact:

Re: Performance problems with SP at HL2DM

Postby La Muerte » Thu Aug 17, 2017 10:44 pm

You should probably also check cpu and memory usage on your linux server
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Sat Aug 19, 2017 3:57 pm

decompile wrote:You should rather try to host a clean server with sp only, we see that you have some addons loaded which otherwise could cause that.


I described in the first Thraid already I had set up a clean server, tested with and without plugins.
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Sat Aug 19, 2017 3:57 pm

La Muerte wrote:You should probably also check cpu and memory usage on your linux server


All other 13 servers are running well
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Sun Aug 20, 2017 12:02 pm

Image
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Sun Sep 03, 2017 8:19 am

The problem always exists
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Mon Sep 11, 2017 6:13 pm

The problem still exist.
I ask all again, to help with the solution of the problem.

Thanks in Advance
User avatar
PhantomDancer
Member
Posts: 42
Joined: Wed Mar 15, 2017 10:39 am
Location: The Great Arctic Hemispheres

Re: Performance problems with SP at HL2DM

Postby PhantomDancer » Mon Sep 11, 2017 6:56 pm

hmm did you try to remove the "source-python.dll" in addons? then, test the server again and see if you still get the fps problem.
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Tue Sep 12, 2017 1:58 pm

Not really an improvement.
User avatar
Ayuto
Project Leader
Posts: 1667
Joined: Sat Jul 07, 2012 8:17 am
Location: Germany

Re: Performance problems with SP at HL2DM

Postby Ayuto » Tue Sep 12, 2017 4:25 pm

Well, that's because you are running a Linux server and source-python.dll is a Windows component. Thus, that library is never used at all on your server and deleting it has no effect.

I guess PhantomDancer's intention was to test whether the performance problems still occur if Source.Python is disabled/not loaded. To do that you better simply move source-python.vdf to a different directory. However, you already mentioned that the problems only occur if Source.Python is loaded.

What's still not clear to me is whether or not you tested the server with only Source.Python being installed and nothing else (no other server plugins and no Source.Python plugins).
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Tue Sep 12, 2017 4:59 pm

English:

I had source python on a fresh server instaliert and before also without tested.
Without source Python ran the server stabiel.

German:

Ich hatte source python auf einen frischen server instaliert und vorher auch ohne getestet.
Ohne source Python lief der server stabiel.
User avatar
Ayuto
Project Leader
Posts: 1667
Joined: Sat Jul 07, 2012 8:17 am
Location: Germany

Re: Performance problems with SP at HL2DM

Postby Ayuto » Tue Sep 12, 2017 5:09 pm

Are you running the same Source.Python version on all servers?
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Tue Sep 12, 2017 5:36 pm

English:

I have only one server with an older version so old plugins continue to run and the is stable. For the other one where the problem is I need the latest version otherwise the plugins do not work the community wrote to me.

German:

Ich habe nur noch einen server mit einer älteren version damit alte plugins weiter laufen und die ist stabiel. Für den anderen wo das problem ist brauch ich die neuste version sonst Funktionieren die Plugins nicht die mir die community geschrieben hatt.
User avatar
Ayuto
Project Leader
Posts: 1667
Joined: Sat Jul 07, 2012 8:17 am
Location: Germany

Re: Performance problems with SP at HL2DM

Postby Ayuto » Tue Sep 12, 2017 6:05 pm

Please try copying the old version to the new server and then test again. If that "fixes" the problem, we need to figure out why the new version causes these problems.

What's the output of "sp info" on your old server?
User avatar
Painkiller
Senior Member
Posts: 315
Joined: Sun Mar 01, 2015 8:09 am
Contact:

Re: Performance problems with SP at HL2DM

Postby Painkiller » Wed Sep 13, 2017 4:33 pm

SP version : 559 old server

SP version : 587 new server

I am also here ready to leave my server to Ayuto.
ggEasy
Junior Member
Posts: 1
Joined: Sun Aug 20, 2017 7:26 pm

Re: Performance problems with SP at HL2DM

Postby ggEasy » Wed Sep 13, 2017 8:23 pm

SetClientListening prehook create heavy lags depending on players/bots online.

Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest